KDE4 4.8.1 > started "public testing" for Mandriva 2010.2

Latest shouts directly from our packagers and call for public testing MIB packages
Post Reply
User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

KDE4 4.8.1 > started "public testing" for Mandriva 2010.2

Post by NicCo »

KDE 4.8.1 announce
http://www.kde.org/announcements/announce-4.8.1.php
Image
KDE 4.8.1 MIB - The very fast and complete Yin/Yang release!
Updated Topic: date 2012/03/20 - time 08:45 a.m. (UTC +01:00)
It can be installed above the previous Mandriva 2010.2 Official KDE 4.4.5 or MIB edition KDE 4.5.5

Main Guide
Image - ITALIANO - clicca qui
Image - ENGLISH
MANDRIVA 2010.2 - KDE 4.8.1
It's available for testing the whole set of packages for KDE4 4.8.1 i686 & x86_64
http://mirror.pianetalinux.org/MIB/2010 ... e4.8/i686/
http://mirror.pianetalinux.org/MIB/2010 ... .8/x86_64/
GENERAL INFO
This new shining KDE could be installed and used as a "stand-alone" project:
even if you have only an official 2010.2 distro, without MIB /basic repository

That's why we have /general repo instead of packaging all those required updates to /basic repository
(they will be only copied to /basic soon but not moved). PLF is also not needed, not other 3rd party repo

We would like the most of users could install this "KDE4 4.8 project" very easily and without any fears...
To install kde 4.8.1 you must add four new repositories
/general, /kde4.8-current, /kde4.8-extra, /kde4.8-prereq

(*) kde4.8-current is a symlink pointing now to http://mib.pianetalinux.org/MIB/2010.2/ ... 4.8-4.8.1/
with upcoming kde release this symlink will be modified to point to newer kde4.8-4.8.2 - kde4.8-4.8.3 - etc., pratically to the latest kde 4.8.x version available,
so you'll can update in a very easy and confortable way, without to modify again your repo config


Image ATTENZIONE > ONLY FOR TESTERS AND ADVANCED USERS! Image

Mandriva 2010.2 - 32bit > Here the command strings to be added in your root konsole - you can choose a> or b>

a) from MIB main server

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 4 fonts for KDE4 4.8 MIB project - 32bit
b) or from MIB Mirror (often offers faster downloads)

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 4 fonts for KDE4 4.8 MIB project - 32bit

Mandriva 2010.2 - 64bit > Here the command strings to be added in your root konsole - you can choose a> or b>
If you are using some 32bit only programs, like acrobat, skype, or others, you may need to add also the 32bit part to have also 32bit libs

a) from MIB main server

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/general/
urpmi.addmedia --update MIB-kde4.8_current_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-prereq/
# If you are using some only 32bit programs, like acrobat, skype, or others, you may need some 32bit libs from 32bit fonts
urpmi.addmedia --update MIB-kde4.8_general_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 8 fonts for KDE4 4.8 MIB project - 64bit arch
b) or from MIB Mirror (often offers faster downloads)

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/general/
urpmi.addmedia --update MIB-kde4.8_current_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-prereq/
# If you are using some only 32bit programs, like acrobat, skype, or others, you may need some 32bit libs from 32bit fonts
urpmi.addmedia --update MIB-kde4.8_general_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 8 fonts for KDE4 4.8 MIB project - 64bit arch
then update everything with the command

Code: Select all

urpmi --auto-select
sometimes you may need to remove some KDE4 xxx -devel related libs or old rpms to have no conflicts and to go forward with the update:
you can temporarely remove some conflicting rpms, when the update is completed if you still need them you can install the newer versions

you can try to repeat the command to verify if everything has been already correctly installed

Code: Select all

urpmi --auto-select

and all that until your rpm update list is empty (no more rpms to update)

ImageIf you have the mib repo /basic enabled, it could ask you to choose between packages related to qt 4.7.4 or newer qt 4.8.x:
naturally you have to select the number corresponding to the newer packages, related to newer qt 4.8.x packages and libs, if NOT and if you choose instead qt 4.7.4 you may have conficts and the install will be stopped,

At the end, after some hundreds of rpms, you can reboot, and Congrats, you are in KDE4 4.8.1


Image - ITALIANO - Vai al Menu
MANDRIVA 2010.2 32bit - KDE 4.8.0
È stato uppato l'intero set di pacchetti KDE4 4.8.1 i686 e x86_64
http://mib.pianetalinux.org/MIB/2010.2/ ... e4.8/i686/
http://mib.pianetalinux.org/MIB/2010.2/ ... .8/x86_64/
INFORMAZIONI GENERALI
Il nuovo e scintillante KDE può essere installato ed usato come un progetto "stand-alone":
anche avendo solo una Distro 2010.2 con i soli pacchetti ufficiali, senza i nostri repo MIB

Per questo abbiamo provveduto a mettere tutti i pacchetti necessari a KDE 4.8 in /general
(questi saranno copiati anche in /basic al momento opportuno) - PLF non è necessario

A noi piacerebbe che la maggior parte degli utenti potesse installare facilmente e senza timori...
[/quote]

Per installare kde 4.8.1 aggiungi quattro nuovi repository
/general, /kde4.8-current, /kde4.8-extra, /kde4.8-prereq

(*) kde4.8-current è in realtà un link simbolico adesso verso http://mib.pianetalinux.org/MIB/2010.2/ ... 4.8-4.8.1/
verrà modificato per puntare su kde4.8-4.8.1 - kde4.8-4.8.2 - ecc., ovvero verso l'ultima release di KDE4 4.8 e rendere gli aggiornamenti 4.8.0 -> 4.8.1 -> 4.8.2 -> 4.8.3 etc, molto semplici e immediati.


Image ATTENZIONE > SOLO PER I TESTER E UTENTI AVANZATI! Image

Mandriva 2010.2 - 32bit > Qui le stringhe di comandi da aggiungere nella konsole di root - da scegliere a> o b>

a) dal MIB main server

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 4 fonts for KDE4 4.8 MIB project - 32bit
b) oppure da MIB Mirror server (spesso è più veloce)

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 4 fonts for KDE4 4.8 MIB project - 32bit

Mandriva 2010.2 - 64bit > Qui le stringhe di comandi da aggiungere nella konsole di root - da scegliere a> o b>
Se stai usando programmi solo 32bit, quali acroread, skype, o altri, ti può servire aggiungere anche i repo 32bit per avere le 32bit libs

a) dal MIB main server

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/general/
urpmi.addmedia --update MIB-kde4.8_current_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_64 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-prereq/
# If you are using some only 32bit programs, like acrobat, skype, or others, you may need some 32bit libs from 32bit fonts
urpmi.addmedia --update MIB-kde4.8_general_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mib.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 8 fonts for KDE4 4.8 MIB project - 64bit arch
b) oppure da MIB Mirror server (spesso è più veloce)

Code: Select all

urpmi.addmedia --update MIB-kde4.8_general_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/general/
urpmi.addmedia --update MIB-kde4.8_current_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_64 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/x86_64/kde4.8-prereq/
# If you are using some only 32bit programs, like acrobat, skype, or others, you may need some 32bit libs from 32bit fonts
urpmi.addmedia --update MIB-kde4.8_general_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/general/
urpmi.addmedia --update MIB-kde4.8_current_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-current/
urpmi.addmedia --update MIB-kde4.8_extra_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-extra/
urpmi.addmedia --update MIB-kde4.8_prereq_32 http://mirror.pianetalinux.org/MIB/2010.2/others/kde4.8/i686/kde4.8-prereq/
# now you have just added 8 fonts for KDE4 4.8 MIB project - 64bit arch
poi aggiorna tutto con il comando

Code: Select all

urpmi --auto-select
a volte può rendersi necessario rimuuovere alcune precedenti librerie KDE4 xxx -devel conflittanti, o altri vecchi programmi per proseguire:
puoi rimuovere temporaneamente ciò che va in conflitto, quando l'aggiornamento ha esaurito tutto i pacchetti, puoi installare le nuove versioni

ripeti the comando di aggiornamento per verificare che tutto sia stato ccorrettamente aggiornato

Code: Select all

urpmi --auto-select

tutto ciò deve essere ripetutto finchè la lista degli rpm da aggiornare risukti completamente vuota

ImageSe hai il repo /basic abilitato con gli aggiornamenti MIB, ti può essere chiesto di scegliere tra pacchetti relativi a qt 4.7.4 o alle nuove qt 4.8.x:
naturalmente dovresti selezionare il numero corrispondente ai pacchetti più nuovi, quelli relativi a pacchetti e librerie qt 4.8.x, diversamente, se sceglessi invece QT 4.7.4, tu sicuramente avresti conflitti e il processo di'installazione sarebbe interrotto per conflitti.

Alla fine, dopo alcune centinaia di rpm, riavvia e, Congratulazioni, adesso sei in KDE4 4.8.1



Ciao, NicCo
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
azioga
Utente senior
Utente senior
Posts: 336
Joined: 8 December 2010, 22:06
ROSA: -
OpenMandriva: 2010.2 32bit
Kernel: 3.2.28-nrj-desktop-p
Desktop: kde 4.5.5
country: italy

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by azioga »

Image


Ottimo lavoro!!

Ciao, Luca.

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by promeneur »

the updating from ke 4.5.5 to 4.8.1 with a mandriva 2010.2 i586 failed
see the log

Code: Select all

............
                                 #############################################
  229/623: granatier             #############################################
  230/623: kdiamond              #############################################
  231/623: kbattleship           #############################################


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-current/plasma-applet-nowplaying-4.8.1-69.1mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-current/plasma-applet-mediaplayer-4.8.1-69.1mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-current/kgoldrunner-4.8.1-69.1mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-current/plasma-applet-pastebin-4.8.1-69.1mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-current/plasma-runner-spellchecker-4.8.1-69.1mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-current/plasma-applet-eyes-4.8.1-69.1mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-current/plasma-wallpaper-marble-4.8.1-69.1mib2010.2.i686.rpm
installation de plasma-applet-mediaplayer-4.8.1-69.1mib2010.2.i686.rpm plasma-applet-nowplaying-4.8.1-69.1mib2010.2.i686.rpm kgoldrunner-4.8.1-69.1mib2010.2.i686.rpm plasma-applet-pastebin-4.8.1-69.1mib2010.2.i686.rpm plasma-runner-spellchecker-4.8.1-69.1mib2010.2.i686.rpm plasma-wallpaper-marble-4.8.1-69.1mib2010.2.i686.rpm plasma-applet-eyes-4.8.1-69.1mib2010.2.i686.rpm depuis /var/cache/urpmi/rpms


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libkipiplugins2-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-2.5.0-69.3mib2010.2.noarch.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-ipodexport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-kopete-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-piwigoexport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-flashexport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libkvkontakte1-1.0.0-0.git20111115.1mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/plasma-applet-yawp-0.4.2-69.1mib2010.2.i686.rpm
installation de libkipiplugins2-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-2.5.0-69.3mib2010.2.noarch.rpm kipi-plugins-ipodexport-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-kopete-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-flashexport-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-piwigoexport-2.5.0-69.3mib2010.2.i686.rpm libkvkontakte1-1.0.0-0.git20111115.1mib2010.2.i686.rpm plasma-applet-yawp-0.4.2-69.1mib2010.2.i686.rpm depuis /var/cache/urpmi/rpms


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/digikam-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libkface1-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libkgeomap1-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libdigikamdatabase2-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libdigikamcore2-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-rawconverter-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libkface-common-2.5.0-69.3mib2010.2.noarch.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libkgeomap-common-2.5.0-69.3mib2010.2.noarch.rpm
installation de digikam-2.5.0-69.3mib2010.2.i686.rpm libkgeomap1-2.5.0-69.3mib2010.2.i686.rpm libkface1-2.5.0-69.3mib2010.2.i686.rpm libdigikamdatabase2-2.5.0-69.3mib2010.2.i686.rpm libdigikamcore2-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-rawconverter-2.5.0-69.3mib2010.2.i686.rpm libkface-common-2.5.0-69.3mib2010.2.noarch.rpm libkgeomap-common-2.5.0-69.3mib2010.2.noarch.rpm depuis /var/cache/urpmi/rpms


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-batchprocess-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-expoblending-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-advancedslideshow-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-htmlexport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-imageviewer-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-flickr-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-sendimages-2.5.0-69.3mib2010.2.i686.rpm
installation de kipi-plugins-batchprocess-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-expoblending-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-advancedslideshow-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-imageviewer-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-htmlexport-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-sendimages-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-flickr-2.5.0-69.3mib2010.2.i686.rpm depuis /var/cache/urpmi/rpms


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libamarokpud1-2.5.0-69.2mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-panorama-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libamarokcore1-2.5.0-69.2mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libamarokocsclient4-2.5.0-69.2mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/amarok-2.5.0-69.2mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-vkontakte-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/amarok-scripts-2.5.0-69.2mib2010.2.noarch.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libamarok-sqlcollection1-2.5.0-69.2mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/libamaroklib1-2.5.0-69.2mib2010.2.i686.rpm
installation de libamarokpud1-2.5.0-69.2mib2010.2.i686.rpm kipi-plugins-panorama-2.5.0-69.3mib2010.2.i686.rpm libamarokcore1-2.5.0-69.2mib2010.2.i686.rpm amarok-2.5.0-69.2mib2010.2.i686.rpm libamarokocsclient4-2.5.0-69.2mib2010.2.i686.rpm kipi-plugins-vkontakte-2.5.0-69.3mib2010.2.i686.rpm amarok-scripts-2.5.0-69.2mib2010.2.noarch.rpm libamaroklib1-2.5.0-69.2mib2010.2.i686.rpm libamarok-sqlcollection1-2.5.0-69.2mib2010.2.i686.rpm depuis /var/cache/urpmi/rpms


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-rajceexport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-kioexportimport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-dngconverter-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-gpssync-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-facebook-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-calendar-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-removeredeyes-2.5.0-69.3mib2010.2.i686.rpm
installation de kipi-plugins-kioexportimport-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-rajceexport-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-dngconverter-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-gpssync-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-facebook-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-removeredeyes-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-calendar-2.5.0-69.3mib2010.2.i686.rpm depuis /var/cache/urpmi/rpms


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-shwup-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-debianscreenshot-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-printimages-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-picasa-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-acquireimages-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-jpeglossless-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-galleryexport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-yandexfotki-2.5.0-69.3mib2010.2.i686.rpm
installation de kipi-plugins-shwup-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-debianscreenshot-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-printimages-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-picasa-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-acquireimages-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-galleryexport-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-jpeglossless-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-yandexfotki-2.5.0-69.3mib2010.2.i686.rpm depuis /var/cache/urpmi/rpms


    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-timeadjust-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-smug-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-extra/kipi-plugins-kmlexport-2.5.0-69.3mib2010.2.i686.rpm
    http://mib.pianetalinux.org/2010.2/others/kde4.8/i686/kde4.8-prereq/polkit-0.104-69.1mib2010.2.i686.rpm
installation de polkit-0.104-69.1mib2010.2.i686.rpm kipi-plugins-timeadjust-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-smug-2.5.0-69.3mib2010.2.i686.rpm kipi-plugins-kmlexport-2.5.0-69.3mib2010.2.i686.rpm depuis /var/cache/urpmi/rpms

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
L'installation a échoué :       le fichier /usr/share/dbus-1/interfaces/org.kde.Konqueror.MainWindow.xml de l'installation de konqueror-1:4.8.1-69.1mib2010.2.i686 entre en conflit avec le fichier du paquetage kdebase4-devel-1:4.5.5-0mdv2010.2.i586
        kdelibs4-devel >= 2:4.5.71 est nécessaire pour kdebase4-workspace-devel-2:4.8.1-69.1mib2010.2.i686
        libweather_ion6 = 2:4.8.1 est nécessaire pour kdebase4-workspace-devel-2:4.8.1-69.1mib2010.2.i686
        libkwinglutils1 = 2:4.8.1 est nécessaire pour kdebase4-workspace-devel-2:4.8.1-69.1mib2010.2.i686
        liboxygenstyleconfig4 = 2:4.8.1 est nécessaire pour kdebase4-workspace-devel-2:4.8.1-69.1mib2010.2.i686
        libkactivities.so.6 est nécessaire pour libpowerdevilcore0-2:4.8.1-69.1mib2010.2.i686
        libkactivities6 = 6:4.8.1-69.1mib2010.2 est nécessaire pour libkactivities-devel-6:4.8.1-69.1mib2010.2.i686
        libkactivities.so.6 est nécessaire pour libtaskmanager4-2:4.8.1-69.1mib2010.2.i686
        kdelibs4-devel >= 2:4.5.60 est nécessaire pour kdebase4-devel-1:4.8.1-69.1mib2010.2.i686
        libattica0.3 = 0.3.0-69.1mib2010.2 est nécessaire pour attica-devel-0.3.0-69.1mib2010.2.i686
        libkcalcore.so.4 est nécessaire pour libkdepim-copy4-3:4.8.1-69.1mib2010.2.i686
        libkcalutils.so.4 est nécessaire pour libkdepim-copy4-3:4.8.1-69.1mib2010.2.i686
        libkatepartinterfaces4 = 2:4.5.5 est nécessaire pour (déjà installé) kdelibs4-devel-2:4.5.5-0.1mdv2010.2.i586
        konsole >= 1:4.8.1 est nécessaire pour kate-3:4.8.1-69.1mib2010.2.i686
        katepart = 3:4.8.1-69.1mib2010.2 est nécessaire pour kate-3:4.8.1-69.1mib2010.2.i686
        kate-extensions = 3:4.8.1-69.1mib2010.2 est nécessaire pour kate-3:4.8.1-69.1mib2010.2.i686
        kdelibs4-core < 2:4.6.90 entre en conflit avec kate-3:4.8.1-69.1mib2010.2.i686
        libgrantlee_core.so.0 est nécessaire pour libkaddressbookprivate4-3:4.8.1-69.1mib2010.2.i686
        libkttsd4 = 2:4.5.5-0mdv2010.2 est nécessaire pour (déjà installé) jovie-2:4.5.5-0mdv2010.2.i586
        libkcalcore.so.4 est nécessaire pour plasma-runner-events-4.8.1-69.1mib2010.2.i686
        kdegraphics4-core < 2:4.6.90 entre en conflit avec kdegraphics-mobipocket-2:4.8.1-69.1mib2010.2.i686
        libkwinnvidiahack4 = 2:4.5.5 est nécessaire pour (déjà installé) kdebase4-workspace-devel-2:4.5.5-0mdv2010.2.i586
.........
etc.

i am going to try again "urpmi --auto-select"
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by NicCo »

promeneur wrote:the updating from KDE 4.5.5 to 4.8.1 with a mandriva 2010.2 i586 failed
see the log
Did you read?

ImageIf you have the mib repo /basic enabled, it could ask you to choose between packages related to qt 4.7.4 or newer qt 4.8.x:
naturally you have to select the number corresponding to the newer packages, related to newer qt 4.8.x packages and libs, if NOT and if you choose instead qt 4.7.4 you may have conficts and the install will be stopped
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
azioga
Utente senior
Utente senior
Posts: 336
Joined: 8 December 2010, 22:06
ROSA: -
OpenMandriva: 2010.2 32bit
Kernel: 3.2.28-nrj-desktop-p
Desktop: kde 4.5.5
country: italy

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by azioga »

perhaps you can try removing kdebase4-devel-1:4.5.5 before update


Ciao, Luca.

User avatar
NicCo
Amministratore
Amministratore
Posts: 4740
Joined: 6 December 2007, 19:54

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by NicCo »

previous suggestion from "Azioga" must be right!

------------
L'installation a échoué : le fichier
/usr/share/dbus-1/interfaces/org.kde.Konqueror.MainWindow.xml
de l'installation de konqueror-1:4.8.1-69.1mib2010.2.i686 entre en conflit avec le fichier du paquetage
kdebase4-devel-1:4.5.5-0mdv2010.2.i586
------------
This error wasn't reported before.
Perhaps usually kdebase4-devel is updated before konqueror.
As a workaround you can remove kdebase4-devel then update.
But for 4.8.2 we'll fix this error and all other reported update issues.

Code: Select all

urpme kdebase4-devel
or

Code: Select all

rpm -e --nodeps kdebase4-devel
then go on to update!
.
--- Professional experience ---
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.

--- currently I'm playing with ---
LTS Kernels > Linux 4.1.12-nrjQL <<< Linux 3.18.17-nrjQL <<< Linux 3.14.46-nrjQL
EOL Kernels > Linux 3.19.8-nrjQL <<< Linux 3.17.8-nrjQL <<< Linux 3.15.10-nrjQL

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by promeneur »

according to avoid updating process stops again and again
then
i manualy uninstalled :
kbugbuster 4.5.5
plasma-applet-kimpanel-scim 4.5.5
kdebase4devel 4.5.5

uninstalling kdebase4-devel 4.5.5 uninstalled task-kde4-devel 4.8.1

after that updating process went smooth till the end

then
i launch again urpmi auto-select
then
urpmi wants to install qt4-examples 4.8.0 !
i answer ok
then
it fails because of a copy error
then
i installed again task-kde4-devel 4.8.1

then
i restarted my pc and opened a kde sesssion
then
now i use kde 4.8.1 software to see if all works


addendum :
i created with virtualbox 4.1.8 a mandriva 2010.2 kde 4.5.5, kernel 3.1.6 desktop identical to my real mandriva 2010.2
this is with this occurence of mandriva i test updating to 4.8.1

mdkapplet wants to update to qt4-examples 4.8.0
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by promeneur »

i found these pb

in kde settings

i must enable again :
- french language to have good units
- dictionary "france-français)
- automatical spelling
- semantical desktop
- nepomuk file indexed
Last edited by promeneur on 10 March 2012, 18:12, edited 1 time in total.
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
Pulfer
Collaboratore
Collaboratore
Posts: 291
Joined: 30 July 2008, 3:10
ROSA: 2012.1 i686
OpenMandriva: -
Kernel: 3.10.x
Desktop: KDE 4.10.x
country: Russia
Location: Vladivostok

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by Pulfer »

promeneur wrote:urpmi wants to install qt4-examples 4.8.0 !
i answer ok
then
it fails because of a copy error
Yes, there is very strange error with this package. I guess it will be fixed in Qt 4.8.1 (which is planned to be released next week or so).
Core i7-3770 / 4 Gb RAM / Gigabyte Z77-D3H / ASUS ENGTS250 / Rosa 2012.1 i686

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by promeneur »

nepomuk file indexer seems not working

i have this error :

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
azioga
Utente senior
Utente senior
Posts: 336
Joined: 8 December 2010, 22:06
ROSA: -
OpenMandriva: 2010.2 32bit
Kernel: 3.2.28-nrj-desktop-p
Desktop: kde 4.5.5
country: italy

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by azioga »

i can only confirm that on my 4.8.1 nepomuk, strigi, akonadi and so on are all working.
with good performance.

maybe because i updated 4.5.5 -> 4.8.0 -> 4.8.1

is the same with a new user?

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by promeneur »

@nicco
If you have the mib repo /basic enabled, it could ask you to choose between packages related to qt 4.7.4 or newer qt 4.8.x:
naturally you have to select the number corresponding to the newer packages, related to newer qt 4.8.x packages and libs, if NOT and if you choose instead qt 4.7.4 you may have conficts and the install will be stopped
it did not ask for me to choose between 4.7.4 and 4.8.0

the result is good : qt4 4.8.0 is installed
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
verg
Utente
Utente
Posts: 107
Joined: 16 February 2011, 15:11
OpenMandriva: 2010.2
Kernel: 2.6.36.4-nrj
Desktop: kDE-4.8.4
country: Russia
Location: St. Petersburg

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by verg »

My advice to install kde4.8 to resolve dependencies:

Code: Select all

# urpmi --allow-force --auto-select --auto-update
Then choosing qt-4.8.0 packages proposed for installation.
And accept the force install (--force) choice during the installation.
Seems no errors. All worked fine and fast.

Tested on mdv2010.2 32bit clean install (full backport/mib/edu/plf)



Thanks for your great work mibbers =)
Last edited by verg on 10 March 2012, 19:20, edited 1 time in total.

User avatar
promeneur
Utente senior
Utente senior
Posts: 547
Joined: 6 February 2009, 17:47
ROSA: -
OpenMandriva: 2010.3 i586
Kernel: 3.5.7 nrj dsktp pae
Desktop: MIB kde 4.8.4
country: France

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by promeneur »

kdepim 4.8.0 is installed instead of 4.8.1 !

i mean all modules : kontact,kaddsressbook,korganiser,akregator
you can see this in menu "help >about"

it's strange because all packets version is 4.8.1 !

i am sure kmail is not 4.8.1 because in kmail 4.8.1 there is a fix i know, this fix is not there then it is a 4.8.0 version
Asus M2N, AMD Athlon 64 X2 5000+, 8 GB, Asus Nvidia 210 silent, Linksys WMP600N, Plugable USB-BT4LE Bluetooth 4.0 Adapter, lecteur multicarte Addonics AEIDDSAU, HP LaserJet 1220

User avatar
verg
Utente
Utente
Posts: 107
Joined: 16 February 2011, 15:11
OpenMandriva: 2010.2
Kernel: 2.6.36.4-nrj
Desktop: kDE-4.8.4
country: Russia
Location: St. Petersburg

Re: KDE4 4.8.1 > started "public testing" for Mandriva 2010.

Post by verg »

promeneur wrote:kdepim 4.8.0 is installed instead of 4.8.1 !
Hmm, have no problem with it.

Post Reply