Kernel 2.6.29.4

Thursday, 21 May 2009 07:48

kernel 2.6.29 logoKernel 2.6.29.4 > Mandriva Linux 2009.1, 2008.1

E adesso, "Forza 4" !
Kernel MIB per Mandriva 2009 Spring: Fix in varie aree, maggiore reattività generale, guadagna 2~5 secondi sul boot dei kernel ufficiali.

 

 

 

 

21 May 2009: ALLARME - fonte SymbianFlo
Sembra vi siano problemi con gli ultimi aggiornamenti kernel ufficiali da Mandriva.
.................................................................................................................................................

24 May 2009: ALLARME - rientrato!
Adesso sembra non vi siano più problemi, chissà cosa è realmente successo

.................................................................................................................................................

 

21 May 2009: Da ieri mattina in /testing:
Kernel x86_64 (64bit) e i686 (32bit) già testati con successo.
Come previsto, sono stati spostati nel repo /MIB-free. Si troveranno al primo aggiornamento.


FILE LIST: sample names
__________________________________________________

kernel-2.6.29.4-69mib-1-1mib2009.1.x86_64.rpm
kernel-desktop-2.6.29.4-69mib-1-1mib2009.1.x86_64.rpm
kernel-desktop-devel-2.6.29.4-69mib-1-1mib2009.1.x86_64.rpm
kernel-desktop-latest-2.6.29.4-69mib2009.1.x86_64.rpm
kernel-desktop-devel-latest-2.6.29.4-69mib2009.1.x86_64.rpm
kernel-server-2.6.29.4-69mib-1-1mib2009.1.x86_64.rpm
kernel-server-devel-2.6.29.4-69mib-1-1mib2009.1.x86_64.rpm
kernel-server-latest-2.6.29.4-69mib2009.1.x86_64.rpm
kernel-server-devel-latest-2.6.29.4-69mib2009.1.x86_64.rpm
kernel-source-2.6.29.4-69mib-1-1mib2009.1.x86_64.rpm
kernel-source-latest-2.6.29.4-69mib2009.1.x86_64.rpm
kernel-doc-2.6.29.4-69mib2009.1.x86_64.rpm
__________________________________________________ 

 

 

HOME: http://www.kernel.org

INFOS: about different kernels:
http://mib.pianetalinux.org/mib/forum/index.php?f=6&t=817&rb_v=viewtopic

 

INTRO: Il MIB, come dovreste sapere, si è occupato a partire dalla Mandriva 2007.1, anche di realizzare delle versioni customizzate (mibizzate) dei vari Kernel per Mandriva Linux, cercando di sopperire alla mancanza di kernel aggiornati, ed in maniera rapida, da fonti ufficiali.

Così è avvenuto inizialmente per la serie 2.6.26.x del Mandriva 2008.1, poi per la serie 2.6.27.x del 2009.0, di seguito per la 2.6.28.x, si continuerà adesso con la serie 2.6.29.x, nativa di Mandriva 2009.1, che cercheremo di supportare per tutte le Distro attualmente suportate dal MIB, ovvero a partire dalla 2008.1, e 2009.0.

 

STORIA: Su Mandriva 2009.1, non abbiamo avuto una grande fretta di rendere immediatamente disponibile un Kernel by MIB, come accadde invece per la Mandriva 2009.0, perchè diversamente da quella, la Mandriva 2009.1 è stata già fornita di un kernel veramente molto buono, stabile e performante.

Dopo aver "Ricominciato da 3" ecco arrivare "Forza 4", il secondo kernel by MIB per la 2009.1.

In settimana proverò a farne un Porting anche per l'altra versione di Mandriva da Noi attualmente supportata, ovvero la 2008.1, ma lì occorrerà ancora qualche modifica, come il oprot del vecchio bootsplash sul kernel 2.6.29.X, e altre cosuccie... speriamo di non riscontrare troppe difficoltà...

Questa sera, se i nostri test saranno tutti molto positivi su diversi PC, esso sarà reso disponibile per tutti.

 

 

STATUS: 21 May 2009.0 - ore 10:00 a.m.

 

Kernel 2.6.29.4 - Porting Status
MandrivaArchitettura
x86_64i686noarch
2009.1Si
Si
X
2008.1WIPWIP
X

 

AVVISO:

 
 Suggestion: If you use proprietary drivers or other dkms

Suggerimento: Per usare driver proprietari (Ati/Nvidia) e altri dkms

IMPORTANT: English zone
To make proprietary video drivers (ati / nvidia) and some others dkms drivers, I remember you need to install also:

  • dkms
  • kernel-devel

And precisely:
if you use kernel-desktop, you need kernel-desktop-devel-latest
if you use kernel-server, you need kernel-server-devel-latest
if you use kernel-desktopi586, you need kernel-desktopi586-devel-latest

 

IMPORTANTE: In Italiano
Per rendere funzionali i driver video proprietari (ati / nvidia) e alcuni altri driver dkms, ricordo che è indispensabile installare:

  • dkms,
  • kernel-devel

E precisamente:
Se usi il kernel-desktop occorre installare kernel-desktop-devel-latest
se usi il kernel-server occorre installare kernel-server-devel-latest
se usi il kernel-desktopi586 occorre installare kernel-desktopi586-devel-latest

 

 

PORTING: da NicCo
BUILDING:
da SymbianFlo

TESTING: da MIB Team testers